Ruby Interpreter Security Vulnerabilities
An official Ruby security advisory was recently issued. We won't go into details here but this issue is a serious one, allowing arbitrary command execution and/or DoS conditions on the affected versions of the intepreter (and if you really want the dirty full disclosure version, Zed Shaw has written up a pretty in-depth analysis).
In any case, if you're using a version of Ruby prior to 1.8.5-p230, 1.8.6-p229, or 1.8.7-p21, you are strongly encouraged to upgrade immediately. Note that if you're running Rails, you must be using 2.1.0 in order to run Ruby 1.8.7. More information is available in the comments on the official Rails blog entry page addressing this. Versions of other Ruby interpreters (JRuby, Rubinius) are not affected by this vulnerability.